Webtext - HTTP/SMPP API Outbound Message Sending Failures – Incident details

HTTP/SMPP API Outbound Message Sending Failures

Resolved
Major outage
Started about 1 month agoLasted about 4 hours

Affected

Messaging API

Major outage from 4:23 PM to 8:45 PM

SMPP

Major outage from 4:23 PM to 8:45 PM

HTTPS

Major outage from 4:23 PM to 8:45 PM

Updates
  • Resolved
    Resolved

    Our recovery efforts were completed at approximately 3:38PM Eastern, and we're seeing stable run-time of messaging services (HTTP, SMPP, etc). Service logging shows that messages are flowing though to our carriers, and validation testing performed by the Care Team has also resulted in successfully received messages.

    Please reach out to the Care Team, if you're still not seeing recovery for any Outbound messaging systems/processes that engage with our end-points.

  • Identified
    Identified

    Our engineering teams have identified a contention issue within our infrastructure, tied to an underlying service that supports the healthy run-time of our Outbound messaging processors. We're taking direct action to get things back into a performant state, and will provide additional details once recovery has been established.

  • Update
    Update

    Our team is actively investigating ongoing delivery issues impacting API message sends over HTTP and SMPP. Restoring normal operation is our top priority.

  • Update
    Update

    We are continuing to investigate the issue affecting message sends via the API through both HTTP and SMPP methods. We’ll share more details as soon as they’re available.

  • Update
    Update
    We are currently investigating this incident.
  • Investigating
    Investigating

    We’re aware of an issue impacting message sends through our API HTTP endpoint.